develooper Front page | perl.wxperl.users | Postings from June 2022

Perl Wx fails to Build -- ProperyGrid.c : error: call of overloaded ‘wxVariant(wxColour&)’ is ambiguous [rt.cpan.org #128994]

From:
james_burwell@apple.com via RT
Date:
June 14, 2022 17:41
Subject:
Perl Wx fails to Build -- ProperyGrid.c : error: call of overloaded ‘wxVariant(wxColour&)’ is ambiguous [rt.cpan.org #128994]
Message ID:
rt-5.0.2-22880-1655158672-1492.128994-15-0@rt.cpan.org
Mon Jun 13 18:17:52 2022: Request 128994 was acted upon.
Transaction: Correspondence added by james_burwell@apple.com
       Queue: Wx
     Subject: Perl Wx fails to Build -- ProperyGrid.c : error: call of overloaded ‘wxVariant(wxColour&)’ is ambiguous [rt.cpan.org #128994]
   Broken in: (no value)
    Severity: (no value)
       Owner: Nobody
  Requestors: imdonp@gmail.com
      Status: open
 Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=128994 >


Thanks again.  Interestingly, I was able to get it to install under perl5.36, built on the same system.

On Mon Jun 13 13:11:20 2022, imdonp@gmail.com wrote:
> I’ll find it for you Weds/Thursday.   (I hope!). I have just started
> updating our Perl stack to 5.34.  So I hope I can find my notes.  But
> I think it was two things and one was that wxPerl did not understand
> versions 5.3x this was last year and 5.32.1 and my memory is rusty. I
> thought I kept notes , or heaven forbid a patch file :-).
> 
> Don Peddicord
> 
> > On Jun 13, 2022, at 12:36 PM, james_burwell@apple.com via RT <bug-
> > Wx@rt.cpan.org> wrote:
> >
> > <URL: https://rt.cpan.org/Ticket/Display.html?id=128994 >
> >
> > Would appreciate that.  I'm using Perl 5.34 and it's pulling and
> > building WxWidgets 3.0.2.  What I don't understand is why it has no
> > issues compiling the same code with Perl 5.21.1 and other older
> > versions of Perl.  One would think that the version of Perl wouldn't
> > matter, unless they made major ABI/bindings changes at some point
> > which break it.
> >
> >> On Fri Jun 10 20:08:57 2022, imdonp@gmail.com wrote:
> >> I think the issue is with wxWidgets. I was able to use 3.0.5.  But I
> >> had to edit a file (in wxPerl) I am not at home.  I found the
> >> solution
> >> via Google. When I get back I will find the answer and post it.
> >>
> >> Don Peddicord
> >>
> >>> On Jun 10, 2022, at 6:53 PM, james_burwell@apple.com via RT <bug-
> >>> Wx@rt.cpan.org> wrote:
> >>>
> >>> <URL: https://rt.cpan.org/Ticket/Display.html?id=128994 >
> >>>
> >>> Same error here trying to build under CentOS7, with Perl 5.34.0.
> >>> It
> >>> builds fine under older versions of Perl like 5.22.1.  Same version
> >>> of Alien::wxWidgets and Wx.  Odd that the only difference is Perl
> >>> versions.
> >




nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About