develooper Front page | perl.wxperl.users | Postings from June 2018

[rt.cpan.org #125603] Wx/Media.so not compiling

From:
kc l via RT
Date:
June 16, 2018 15:05
Subject:
[rt.cpan.org #125603] Wx/Media.so not compiling
Message ID:
rt-4.0.18-13895-1529161491-1601.125603-15-0@rt.cpan.org
Sat Jun 16 11:04:50 2018: Request 125603 was acted upon.
Transaction: Ticket created by eletik97@gmail.com
       Queue: Wx
     Subject: Wx/Media.so not compiling
   Broken in: (no value)
    Severity: (no value)
       Owner: Nobody
  Requestors: eletik97@gmail.com
      Status: new
 Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=125603 >


Hello,

I am trying to get Wx installed.  I ran into a trouble similar to reported
in bug report "#105468: 01-load.t: Can't locate Wx/Media.pm"

I traced it to being Media.so is not being compiled because the Makefile in
the ext/media directory does not contain any instruction for building the
target.  It seems like a few other 'submodules' in the ext/ directory are
similarly affected.  I have followed the bug reports' suggestion and I
believe I have all the dependencies installed.  I would like to learn to
fix this bug myself since it seems straight forward if I can figure out how
to gather more information or figure out how the compilation process work.
I am sorry I am a novice when it comes to XS, could you help me get started
with where to look?  I would really appreciate it.

I am running on a Ubuntu 14.04.

Thank you,
KC Lee



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About