develooper Front page | perl.wxperl.users | Postings from April 2017

[rt.cpan.org #121224] key codes are not valid for older Wx versions

Thread Previous
From:
tcallawa@redhat.com via RT
Date:
April 17, 2017 18:48
Subject:
[rt.cpan.org #121224] key codes are not valid for older Wx versions
Message ID:
rt-4.0.18-13598-1492454903-630.121224-15-0@rt.cpan.org
Mon Apr 17 14:48:23 2017: Request 121224 was acted upon.
Transaction: Ticket created by tcallawa@redhat.com
       Queue: Wx
     Subject: key codes are not valid for older Wx versions
   Broken in: 0.9931
    Severity: (no value)
       Owner: Nobody
  Requestors: tcallawa@redhat.com
      Status: new
 Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=121224 >


The nicer key codes (e.g. WXK_CONTROL_A) were not added until wx 2.9.2, but Constant.xs thinks that anything less than 3.0.2 has them. This fix resolves the build failure against the 2.8 Wx code.

--- Wx-0.9931/Constant.xs.fixes 2017-04-17 14:41:38.466618321 -0400
+++ Wx-0.9931/Constant.xs       2017-04-17 14:41:43.873484635 -0400
@@ -1817,7 +1817,7 @@ static double constant( const char* name
   case 'K':
     if( strnEQ( name, "WXK_", 4 ) )
     {
-#if WXPERL_W_VERSION_LT( 3, 0, 2 )
+#if WXPERL_W_VERSION_GE( 2, 9, 2 )
         r( WXK_NONE );                  // keycode
         r( WXK_CONTROL_A );             // keycode
         r( WXK_CONTROL_B );             // keycode

Thread Previous


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About