develooper Front page | perl.wxperl.users | Postings from March 2017

[rt.cpan.org #118284] Perl-Wx can not be built with STL variants ofwxWidgets

Thread Previous
From:
Ron Grunwald via RT
Date:
March 21, 2017 14:08
Subject:
[rt.cpan.org #118284] Perl-Wx can not be built with STL variants ofwxWidgets
Message ID:
rt-4.0.18-10150-1490105283-1046.118284-15-0@rt.cpan.org
Tue Mar 21 10:08:02 2017: Request 118284 was acted upon.
Transaction: Correspondence added by rongrw
       Queue: Wx
     Subject: Perl-Wx can not be built with STL variants of wxWidgets
   Broken in: (no value)
    Severity: (no value)
       Owner: Nobody
  Requestors: stefan.bruens@rwth-aachen.de
      Status: new
 Ticket <URL: https://rt.cpan.org/Ticket/Display.html?id=118284 >


On Thu Oct 06 20:32:27 2016, stefan.bruens@rwth-aachen.de wrote:

> Note - If you built wxWidgets with wxUSE_STL set to 1, the implicit
> conversions to both narrow and wide C strings are disabled and
> replaced with
> implicit conversions to std::string and std::wstring.

Hi Stefan,

From your description of the problem, if we execute the following
command line in Alien-wxWidgets,

perl Build.PL --wxWidgets-extraflags="--enable-stl"

would that then allow Wx to build successfully against version 3.0.2?
Is this what you did?

Kind regards,

Ron.

Thread Previous


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About