develooper Front page | perl.tcltk | Postings from March 2019

Drop support for Tcl/Tk 8.4?

Thread Next
From:
Christopher Chavez
Date:
March 27, 2019 08:30
Subject:
Drop support for Tcl/Tk 8.4?
Message ID:
3DA5F723-8C70-4B0A-8276-3198222E2F67@gmx.us
Hi all,

I am proposing to drop support for Tcl/Tk 8.4 from Tcl::pTk. This is mainly because:

  1. the developers of Tcl/Tk have no longer supported 8.4 for some time, and have encouraged anyone using it to upgrade;
  2. many binary Tcl/Tk distributions and OS package managers no longer provide 8.4; and
  3. I personally have not tested Tcl::pTk on Tcl/Tk 8.4 for these reasons.

I have not thought of any immediate or significant benefits to the Tcl::pTk codebase other than being able to remove checks for whether Tcl/Tk 8.5+ is present before using features such as Tile/Ttk.

I will go ahead and bump the Tcl::pTk version to 1.00 if I drop Tcl/Tk 8.4.

I do not suspect that any of the active Tcl::pTk users I have heard from over the past several months are using Tcl/Tk 8.4, but please respond in case of objections to (or approval of :^) ) this proposal.

I currently do not have any plans to drop support for Tcl/Tk 8.5, since some platforms still ship with 8.5 (e.g. macOS).


Christopher A. Chavez
Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About