develooper Front page | perl.qpsmtpd | Postings from December 2018

Re: qpsmtpd won't start, can't access Net/IP.pm

Thread Previous
From:
=?UTF-8?B?S2V2aW7igJlzIFBoYWly?=
Date:
December 17, 2018 14:50
Subject:
Re: qpsmtpd won't start, can't access Net/IP.pm
Message ID:
CAGBfrTC_xxpPvdY0rr6-LE6hV+A=9rvVwDCRSV1YALbB8z_LEA@mail.gmail.com
Are you sure that Net::IP was installed against the same perl you are using
for qpsmtpd? I'm not that familiar with gentoo, but
https://gitweb.gentoo.org/repo/gentoo.git/tree/mail-mta/qpsmtpd/qpsmtpd-0.84-r2.ebuild
suggests that it wasn't listed as a depdency. It also looks like Net::IP
isn't a dependency of qpsmtpd itself, but of the plugin listed in your
error message.

On Sun, Dec 16, 2018 at 7:19 PM <qpsmtpd@jrd.org> wrote:

> Hi all.  I'm putting together a new server, using qpsmtp.
>
> I'm running up to date gentoo, using the gentoo ebuild for
> qpsmtpd-0.84-r2.
>
> When I go to start the service, it fails.  Debugging a little, strace
> reveals that as the server starts up, it's trying to stat
> lib/Net/IP.pmc and lib/Net/IP.pm.  Those fail.  It then says
>
> eval Can't locate Net/IP.pm:   lib/Net/IP.pm: Permission denied at
> /usr/share/qpsmtpd/plugins/check_relay line 5.
> BEGIN failed--compilation aborted at
> /usr/share/qpsmtpd/plugins/check_relay line 5.
>
> Looking back in the strace history, there are other modules which it
> successfully finds, for instance Net/DNS.pm.  For those, after
> stat'ing lib/Net/DNS.pm, it goes on to search for others in the
> usual places until it finds it.  It's almost as if something were
> bashing the value of @INC partway through, but that's hard to
> swallow.
>
> Does this ring any bells?  I expect it's some sort of stupid
> configuration problem.
>
> Thanks in advance for any hints.
>

Thread Previous


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About