develooper Front page | perl.qa | Postings from November 2016

Devel::Cover broken on Perl 5 blead

Thread Next
From:
James E Keenan
Date:
November 14, 2016 16:29
Subject:
Devel::Cover broken on Perl 5 blead
Message ID:
cb821960-2ff2-3200-fddc-eef2fcb1a7e8@verizon.net
Devel::Cover is failing to build on most versions of Perl 5 blead (5.25.-*).

See http://matrix.cpantesters.org/?dist=Devel-Cover, where most reports 
are ending as UNKNOWN or FAIL for 5.25.2 and later.

Today, while testing the proposed -Ddefault_inc_excludes_dot switch, I 
build perl 5, installed 'cpanm' against that perl, and invoked 'cpanm' 
to install the modules I use all the time.  Devel::Cover failed during 
'make'.  I'm attaching (a) an excerpt from the cpanm build log; and (b) 
most of the output of perl -V for this build.

Thank you very much.
Jim Keenan

Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About