develooper Front page | perl.qa | Postings from March 2005

Re: Test::META

From:
Christopher H. Laco
Date:
March 27, 2005 18:20
Subject:
Re: Test::META
Message ID:
424769E9.8020905@chrislaco.com
Michael G Schwern wrote:
> On Sun, Mar 27, 2005 at 08:32:59PM -0500, Christopher H. Laco wrote:
> 
>>Along the lines of converting to Module::Build...it went well until I 
>>started doing tests...things that worked  now break, probably do to how 
>>they're now run...
>>
>>t\xsp.............Use of uninitialized value in transliteration (tr///) 
>>at C:/Development/Perl/584/lib/File/Spec/Win32.pm line 99.
>>Use of uninitialized value in pattern match (m//) at 
>>C:/Development/Perl/584/lib/File/Spec/Win32.pm line 101.
>>Use of uninitialized value in transliteration (tr///) at 
>>C:/Development/Perl/584/lib/File/Spec/Win32.pm line 99.
>>Use of uninitialized value in pattern match (m//) at 
>>C:/Development/Perl/584/lib/File/Spec/Win32.pm line 101.
>>
>>The path '' is not an absolute path. Please specify an absolute path
>>
>>The path '' is not an absolute path. Please specify an absolute path
>>
>>The path '' is not an absolute path. Please specify an absolute path
> 
> 
> That's odd, its not where I'd have expected breakage.  Want to post your
> MakeMaker and MB versions so we can poke at them?
> 
> 
I rolled back. I'm have to reconsicrate my Build.PL tomorrow.
I want to tinker a bit more tomorrow to rule out user stupidity.

My bet is that the shebang -w in my *.t files are kicking in where they 
weren't before; pointing to a difference in how they're invoked between 
the two envorinments.

Along those lines, CTRL-C, CTRL-D, and "Terminate batch job.. Y" never 
got me out of the loop:

 >>The path '' is not an absolute path. Please specify an absolute path

My only recourse was to terminate the CMD window.

-=Chris



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About