develooper Front page | perl.php.sandwich.dev | Postings from November 2005

Re: PHP::Interpreter for mere mortals

Thread Previous | Thread Next
From:
George Schlossnagle
Date:
November 10, 2005 07:47
Subject:
Re: PHP::Interpreter for mere mortals
Message ID:
43736B6B.4020304@omniti.com
Geoffrey Young wrote:

>hi guys :)
>
>I've been struggling for a few days trying to get PHP::Interpreter compiled
>and running.  I'm using stock fedora core 3 with perl 5.8.7 (shown below).
>I figure that I'm really just missing something over in my php compliation,
>since I'm the least familiar with that, but who knows.
>
>basically, I'm starting from php 5.0.5 like this
>
>  $ ./configure --with-apxs=/apache/1.3/dso/perl-5.8.7/bin/apxs --with-mysql
>--enable-embed && make && sudo make install
>  
>

The PHP SAPIs (excluding CLI) are mutually exclusive.  I suspect that 
your apxs build is trouncing your embed SAPI build.  It's probably clear 
at the end of the build process when it links and installs the .so's.   
The xml issue is probably a byproduct of  that, but it also looks like 
perhaps you are building against one set of headers and linking against 
another object.  PHP::Interpreter doesn't do anything with XML, so that 
is probably your PHP .so which is having the link problem.

I know that's not too helpful, but I thnk some judicious use of ldd can 
help turn up where the problem is.

George

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About