develooper Front page | perl.perl6.users | Postings from December 2019

about 'use v6.d'

Thread Next
From:
MT
Date:
December 13, 2019 09:09
Subject:
about 'use v6.d'
Message ID:
b4a7f984-e4b8-bf2d-9b08-32fbdeefa9da@gmail.com
Hello all,

In the light of renaming to Raku I was wondering if the statement 'use 
v6.*' is still useful.

First there is no version 6 of Raku (should be version 0, but that's 
another story) and the 'use v5' in the past used for perl5 is also not 
used anymore (I think) (it is, I believe, more common to 'use 
Inline::Perl5').

Also the 'd' of the Diwali version is a nice touch but my experience is 
that this is not accurate enough. I've used some new things of Raku 
introduced somewhere in summer 2019 but the version is still 6d. Also 
many bugs are fixed which requires newer versions to run right.

So I must warn potential users of the software to install the newest 
Raku version, otherwise the programs/modules will run into problems.

It would be nice to have this version extended, or maybe better, the 
version spec in META6.json so that the zef module installer could hold 
back the installation if the users Raku version is older. It is not 
enough to let tests fail on something the Raku compiler cannot handle 
because it is does not show that the compiler is too old when zef is 
installing modules.

Regards
Marcel

Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About