develooper Front page | perl.perl6.users | Postings from October 2018

Re: zef installs not working

Thread Previous | Thread Next
From:
Todd Chester via perl6-users
Date:
October 17, 2018 03:50
Subject:
Re: zef installs not working
Message ID:
871cf690-dbf4-6031-329b-b176b41ccc1c@zoho.com


On 10/16/18 8:20 PM, Joseph Brenner wrote:
> Lately zef hasn't been working for me to do module installation.
> I can do things like "zef --list" to get a list of available
> modules but when I actually try to do the installation I see
> things like this:
> 
>    zef install Array::Agnostic
> 
>    ===> Searching for: Array::Agnostic
>    ===> Testing: Array::Agnostic:ver<0.0.6>:auth<cpan:ELIZABETH>
>    ===SORRY!===
>    Object does not exist in serialization context
>    ===> Testing [FAIL]: Array::Agnostic:ver<0.0.6>:auth<cpan:ELIZABETH>
>    Aborting due to test failure:
> Array::Agnostic:ver<0.0.6>:auth<cpan:ELIZABETH> (use --force-test to
> override)
> 
> And no, using --force-test only gets me a little further, it
> still fails with "Object does not exist in serialization context".
> 
> Any suggestions on what that might mean?
> 
> 
> 
> perl6 --version
> This is Rakudo Star version 2018.06 built on MoarVM version 2018.06
> implementing Perl 6.c.
> 

Hi Joseph,

What I do is to go to the github source for the module:

https://github.com/lizmat/Array-Agnostic

Then I "Clone or Download" (green button on the right middle).
I usually download it as a "zip".  Then I unzip it to a directory.

Next I cd into the directory and install it with

    zef install .

HTH,
-T

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About