develooper Front page | perl.perl6.stdlib | Postings from August 2000

Re: Define consistent and standard

From:
Gisle Aas
Date:
August 4, 2000 10:35
Subject:
Re: Define consistent and standard
Message ID:
m3u2d11akw.fsf@eik.g.aas.no
Michael Fowler <michael@shoebox.net> writes:

> On Fri, Aug 04, 2000 at 10:37:02AM +0100, Leon Brocard wrote:
> > Michael Fowler sent the following bits through the ether:
> > 
> > > Personally, I think FindBin is a bit of a sore thumb.  Its name, the
> > > capitalization of its variable names
> > 
> > I suppose we could try and define some Perl Naming Conventions - ie
> > instead of DumpCore() we should have dump_core(). This'll really annoy
> > Java programmers. Other ideas needed though...
> 
> I think no matter what is decided, consistency-wise, someone is going to be
> unhappy with it.  If we use DumpCore() the C programmers won't like us,
> dump_core() and the C++ and Java programmers will throw fits.  I think the
> best thing we can do is decide on what -Perl- programmers want. 
> Unfortunately, this is rather difficult to pin down, but we should probably
> take hints from the language itself.
> 
> I'm going to wait until Gisle Aas puts out his RFC, and bat it around at
> that point.

I don't think I promised to do anything.  You must be waiting for
somebody else.

--Gisle

>             That way we have a list of what needs to be made consistent
> (methods look like this, variables that do this look like that, etc.) and
> what needs to be made consistent (this module isn't consistent, fix it)
> [intentional redundancy there].



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About