develooper Front page | perl.perl6.language | Postings from February 2001

Re: Auto-install (was autoloaded...)

Thread Previous | Thread Next
Clayton Scott
February 13, 2001 05:30
Re: Auto-install (was autoloaded...)
Message ID:
Branden wrote:
> And I'll probably ask you to use another naming/extension, like pp5 (par for
> perl 5), so that modules for both versions don't get mixed up (since they'll
> be incompatible).

	That doesn't make sense. Either your script or your archive
 tool (par, pun, or CPAN or whatever) should know what perl interpreter
 to use without have to have a .pp5, .pp5.6, .pp5.6.1. The script
 should 'require 5.6' (and you'll get an error like 
 Perl 5.6 required--this is only version 5.00503, stopped at -e line 1.
 and your perl interpreter will deal with it. That and/or it would be
 nice if a metadata document came as a part of the archive that was
 easy to query for details e.g.

	par --perl_version my_cool_script.par
	or from the CPAN shell:
	CPAN> install my_cool_script.par for 5.6

> Other than that, I believe developping it for Perl 5 is a very good idea,

	Perl 5 is not dead and will not be for a long, long time.
 Building it first with perl 5 for perl 5 should be a no brainer.


Thread Previous | Thread Next Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at | Group listing | About