develooper Front page | perl.perl6.compiler | Postings from April 2018

[perl #133107] LTA: require of non installed module

Thread Previous | Thread Next
From:
Martin Barth
Date:
April 13, 2018 06:34
Subject:
[perl #133107] LTA: require of non installed module
Message ID:
rt-4.0.24-21822-1523601283-291.133107-82-0@perl.org
# New Ticket Created by  Martin Barth 
# Please include the string:  [perl #133107]
# in the subject line of all future correspondence about this issue. 
# <URL: https://rt.perl.org/Ticket/Display.html?id=133107 >


requireing a non installed module leads to strange error if the name 
starts with the name of a core module. e.g:


 > perl6 -e 'require IO::Socket::Async::SSL'
IO::Socket::Async::SSL is a builtin type, not an external module
   in block <unit> at -e line 1

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About