develooper Front page | perl.perl5.porters | Postings from September 2022

Rfc 0006 - "load" is a terrible name

Thread Next
From:
demerphq
Date:
September 19, 2022 13:29
Subject:
Rfc 0006 - "load" is a terrible name
Message ID:
CANgJU+Um4-_JEXzc=zP83QDO4R_ZmgvoVSQS+YV6OSa3hmgvcQ@mail.gmail.com
builtin::load() is far too generic a name. We should err on the side of
specificity and avoid generic keywords like this. What happens if in the
future we realize we have other things we might "load"?

Please please change the name to something more specific. I am convinced we
will regret this choice. I bet if you did a search for "sub load" in any
large codebase you would find dozens of cases. CPAN also. Philippe how many
such subs does booking have?

I can think of handful of alternate names that would all be better. Let's
use one of them instead. "load_module" "require_module", "load_package",
"require_package", whatever. Just *not* something so generic as "load".

Cheers
Yves

Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About