Karl Williamson <public@khwilliamson.com> wrote: : From reading that discussion, I think you would be more comfortable :with something like this: : : while (s < e) { : if (! next_uvchr(s, e, &ret_cp, &ret_len)) { : ... process error ... : } : else { : ... process code_point ... : } : : s += ret_len; : } That certainly feels like a cleaner design to me, by avoiding the overloading of ret_len to have multiple meanings. :I would consider this. I designed the original proposal to be more of a :drop-in replacement for the current one. But this one gets rid of the :flag to say you want errors, and might be close enough to drop-in. I :await more people to weigh-in. Thanks for considering it. HugoThread Previous | Thread Next