develooper Front page | perl.perl5.porters | Postings from August 2021

Re: "use v5.36.0" should imply ASCII source

Thread Previous | Thread Next
From:
Graham Knop
Date:
August 16, 2021 12:05
Subject:
Re: "use v5.36.0" should imply ASCII source
Message ID:
CAM=m89F8uQXPQBymM+Uq+F9MDTqbrp=7skPaaXc+74HDDv-y5w@mail.gmail.com
On Fri, Aug 6, 2021 at 8:23 PM Paul "LeoNerd" Evans
<leonerd@leonerd.org.uk> wrote:
> It's far easier for everyone - implementation and users alike - to give
> a very simple rule:
>
>   After `use VERSION>=5.36` and until any `use utf8` there must be no
>   non-ASCII bytes whatsoever.

This would need the addition of "unless they are after an __END__
marker". I think it will inevitably make the rules for UTF-8 Pod
confusing.

>
> Yes this does lead to an annoying dual declaration of both `use utf8`
> and `=encoding UTF-8` - perhaps that can be helped in some way?

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About