develooper Front page | perl.perl5.porters | Postings from June 2021

Re: use v5.36; use warnings;

Thread Previous | Thread Next
From:
Dan Book
Date:
June 18, 2021 20:26
Subject:
Re: use v5.36; use warnings;
Message ID:
CABMkAVW-dTNPkgOeSimh48peUsu1ryaQZDOVxN1y9Fw5y2FqwQ@mail.gmail.com
On Fri, Jun 18, 2021 at 4:23 PM Dan Book <grinnz@gmail.com> wrote:

>
> This sounds reasonable to me. We should *not* retroactively make it turn
> off strict or warnings on older versions, but unconditionally enabling it
> on the new versions would be more intuitive.
>

To clarify: I think the goal of making "use strict; use v5.10;" keep strict
on was correct, and we should keep supporting that, and do the same for
warnings. But "no strict; use v5.12;" should (after appropriate
deprecation) enable strict.

-Dan

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About