develooper Front page | perl.perl5.porters | Postings from June 2021

Re: RFC 0004 - defer {} syntax

Thread Previous | Thread Next
Tom Molesworth via perl5-porters
June 17, 2021 14:01
Re: RFC 0004 - defer {} syntax
Message ID:
On Thu, 17 Jun 2021 at 21:32, David Nicol <> wrote:

> i like "ON_EXIT" better as a name for the block.

Two issues I'd raise with this suggestion:

- the RFC explicits covers reasons not to use ALL-CAPS for naming.
Alternative suggestions should at least address those reasons with
- it's triggered by scope end, not exit... so we'd be inconsistent with
both exit() (the keyword), and END (the phaser)

Thread Previous | Thread Next Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at | Group listing | About