develooper Front page | perl.perl5.porters | Postings from June 2021

Re: CI fails from mingw64

Thread Previous
From:
Karl Williamson
Date:
June 15, 2021 17:22
Subject:
Re: CI fails from mingw64
Message ID:
ae16a3d2-228d-8bf6-784c-92626318aacd@khwilliamson.com
On 6/15/21 10:39 AM, Paul "LeoNerd" Evans wrote:
> The github CI testing machine for Windows mingw64 always fails lately.

https://github.com/Perl/perl5/issues/18866


> 
> The details of the failure are:
> 
>   re/uniprops01.t (Wstat: 2304 Tests: 0 Failed: 0)
>    Non-zero exit status: 9
>    Parse errors: No plan found in TAP output
> 
> because:
> 
>   re/uniprops01.t ......................................................
>   Dubious, test returned 9 (wstat 2304, 0x900)
>   No subtests run
> 
> no deeper indications why.
> 
> It fails on every single commit/PR, in a way that none of the others
> do; not even the Windows msvc142.
> 
> I've been ignoring it lately and I think so has everyone else.
> 
> Does anyone have a plan of what to do about it? Do we
> 
>   0) Continue to ignore it
> 
>   1) Remove it from the CI set as we don't seem to get any useful
>      information out of it
> 
>   2) Investigate why it fails and maybe fix it?
> 
> 
> I don't want to continue to have to remember to ignore that red X mark,
> because I don't want to train myself into ignoring CI failures as doing
> that will eventually cause me to overlook a real failure.
> 


Thread Previous


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About