develooper Front page | perl.perl5.porters | Postings from June 2021

Re: use warnings ':most'

Thread Previous | Thread Next
From:
Felipe Gasper
Date:
June 6, 2021 21:03
Subject:
Re: use warnings ':most'
Message ID:
7AC3CCBC-1103-41BE-968B-6DEF8E1AE1A6@felipegasper.com


> On Jun 6, 2021, at 16:31, Leon Timmermans <fawaka@gmail.com> wrote:
> 
> 
>> On Sun, Jun 6, 2021 at 10:15 PM Dan Book <grinnz@gmail.com> wrote:
>>> On Sun, Jun 6, 2021 at 4:03 PM Ricardo Signes <perl.p5p@rjbs.manxome.org> wrote:
>> 
>>> …and I still think that "use v5.X" should mean "use warnings 'default'" and that default should exist.
>>> 
>>> I think it should mean what "all" means now, though, including "once."  Let's first create default, meaning all the current warnings, then we can separately discuss what warnings might get excluded?
>> 
>> I don't think 'default' is a good name for it, since it's already used to describe warnings which are enabled without any use of the warnings pragma (e.g. severe and deprecation warnings).
>> 
>> -Dan 
> 
> Agreed. Probably someone can come up with a better than than 'most', but 'default' is kind of confusing (and 'standard' may also be)

use warnings ':5.36'?

-F
Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About