develooper Front page | perl.perl5.porters | Postings from June 2021

Re: G_ARRAY should be called G_LIST

Thread Previous | Thread Next
Yuki Kimoto
June 1, 2021 01:59
Re: G_ARRAY should be called G_LIST
Message ID:
2021-5-31 23:08 Paul "LeoNerd" Evans <> wrote:

> Yes, G_ARRAY.
> I propose to add a new G_LIST constant with the same value as the
> current G_ARRAY, and perform a simple s/G_ARRAY/G_LIST/ across our
> codebase to fix up this little cognitive roadbump.
> I imagine adding a back-compat constant to ppport.h and similar should
> be relatively straightforward.
> Any objections?

My personal view.

If G_ARRAY is an internal constant, it is no problem.

On the other hand, If G_ARRAY is published, and used in some CPAN modules,
it has some problems.

I think G_LIST is the best name, but G_ARRAY is not so bad.

Adding G_LIST adds another complexity because the meanings of G_LIST and
G_ARRAY are duplicated.

Paul is motivated and seems to want to experiment with the Perl core, so I
don't strongly oppose it.

Thread Previous | Thread Next Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at | Group listing | About