develooper Front page | perl.perl5.porters | Postings from April 2021

Re: on changing perl's behavior

Thread Previous | Thread Next
From:
Yuki Kimoto
Date:
April 7, 2021 00:24
Subject:
Re: on changing perl's behavior
Message ID:
CAExogxMf4cgd1xWV5Pyfo2Qp-yXVY1XbYPudyBsYGJGizVSxTA@mail.gmail.com
rjbs

----------
On Sun, Apr 4, 2021, at 7:58 PM, Yuki Kimoto wrote:

Personally, why not use the following syntax

use v5.26;
use v5.28;
use v5.30;
use v5.32;

1. that don't include warnings program.

2. The features introduced in the minor version are hard to understand. It
feels like a feature that early adopters try.


I don't understand what you mean, especially by point #2.
------------

Suppose I am a beginner.

I can't understand the difference between "use v5.26" and "use v5.32".

This is because the unit for minor releases is too small.

If it is "use v7;", I can understand the features by reading only one page
that explains it.


2021年4月5日(月) 9:30 Ricardo Signes <perl.p5p@rjbs.manxome.org>:

> On Sun, Apr 4, 2021, at 7:58 PM, Yuki Kimoto wrote:
>
> Personally, why not use the following syntax
>
> use v5.26;
> use v5.28;
> use v5.30;
> use v5.32;
>
> 1. that don't include warnings program.
>
> 2. The features introduced in the minor version are hard to understand. It
> feels like a feature that early adopters try.
>
>
> I don't understand what you mean, especially by point #2.
>
> --
> rjbs
>

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About