develooper Front page | perl.perl5.porters | Postings from April 2021

Re: Should `use v5.34` enable warnings?

Thread Previous | Thread Next
From:
Leon Timmermans
Date:
April 2, 2021 14:51
Subject:
Re: Should `use v5.34` enable warnings?
Message ID:
CAHhgV8jyDxAPsG6iR07dfA4B6cXe--7b=-9wULEZCDiTKSRFxg@mail.gmail.com
On Mon, Mar 22, 2021 at 4:49 PM Paul "LeoNerd" Evans
<leonerd@leonerd.org.uk> wrote:
>
> There is much talk afoot of resurrecting various forms of the "Perl 7"
> plan, including default warnings.
>
> The question has been asked before [1] and was rejected at the time
> because it felt like an overly-big change that was unrequested by users.
>
> Again, in the face of the proposal of "we're thinking of changing the
> baked-in defaults even without being requested", I really think this
> change warrants another look.
>
> I could write a PR for this to make
>
>   use v5.34;
>
> turn on warnings by default, and raise it as a possible question of
> whether we should consider it.
>
>
> [1]: https://github.com/Perl/perl5/issues/17162

I took the liberty to write such a branch at
https://github.com/Perl/perl5/pull/18666.

It's just a draft (no docs/tests yet; volunteers are welcome), but it
does exactly that it says on the tin.

Leon

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About