develooper Front page | perl.perl5.porters | Postings from March 2021

Re: Devel::NYTProf on blead [issue 18215]

Thread Previous | Thread Next
From:
Leon Timmermans
Date:
March 21, 2021 22:40
Subject:
Re: Devel::NYTProf on blead [issue 18215]
Message ID:
CAHhgV8jNw84cUEtxc2NQfYW07fZerqrHcf3RgrrMX0aqgJ9DXA@mail.gmail.com
On Sun, Mar 21, 2021 at 7:36 PM Ricardo Signes
<perl.p5p@rjbs.manxome.org> wrote:
> Is there anyone who could volunteer to undertake fixing this?  It's plausible that a fix to simply have two sets of expectations, one pre-strict and one post-strict, is reasonable.  We can't really decide that, though, until somebody investigates the specific causes of this breakage.

A dumb fix like that is easy to do, but not very scalable. It's going
to break again as soon as someone adds «use warnings;» to Exporter,
and then we're left with three pieces.

Another crude but effective fix might be to rewrite that test so that
it doesn't use Exporter, but I kind of suspect that's going to break
other things.

All of this is fragile in ways that seem non-trivial to make non-fragile.

Leon

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About