develooper Front page | perl.perl5.porters | Postings from March 2020

RE: "require" change of behavior in 5.16 or slightly before?

Thread Previous | Thread Next
From:
Konovalov, Vadim
Date:
March 2, 2020 15:14
Subject:
RE: "require" change of behavior in 5.16 or slightly before?
Message ID:
BN6PR19MB3251C319312653F710A586148AE70@BN6PR19MB3251.namprd19.prod.outlook.com
I assume this is why perl is in now not modern anymore:

When I had similar problems (rt ticket #127512), perl-porters refused to accept them, accusing me (user) to these problems

While you think that "modernizing" perl is stuffing "use strict; use warnings;" every where - sane people would think about introducing some modern concepts like "WebPerl"
However the further we go - the harder to get with "webperl" because of dependencies forest.

Yet, now mails are filtered out

Congratulations: you win your own exclusive echo chamber! 😊

-----Original Message-----
From: Dave Mitchell <davem@iabyn.com> 
Sent: Tuesday, February 25, 2020 1:40 PM
To: Philip Prindeville
Cc: perl5-porters@perl.org
Subject: Re: "require" change of behavior in 5.16 or slightly before?


[EXTERNAL EMAIL] 

On Wed, Feb 19, 2020 at 09:41:49AM -0700, Philip Prindeville wrote:
> I have some build scripts that used to work in perl-5.10 and when we updated to perl-5.16 one in particular broke badly.

I assume this a duplicate of your email from 19th Feb and can be ignored.

-- 
"Do not dabble in paradox, Edward, it puts you in danger of fortuitous wit."
    -- Lady Croom, "Arcadia"

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About