develooper Front page | perl.perl5.porters | Postings from May 2019

[perl #134023] perl5 blead fails to build on NetBSD-8.0 with g++

From:
James E Keenan via RT
Date:
May 22, 2019 12:48
Subject:
[perl #134023] perl5 blead fails to build on NetBSD-8.0 with g++
Message ID:
rt-4.0.24-25188-1558529287-1994.134023-15-0@perl.org
On Wed, 22 May 2019 12:04:13 GMT, coypu@sdf.org wrote:
> On Wed, 22 May 2019 05:03:18 -0700, coypu@sdf.org wrote:
> > Is a fix for Perl also desired?
> 
> And by fix I mean, "hack workaround", hence the question :-)
> 
> 

Yes, a fix is desired.  It appears evident to me (note: note a NetBSD user) that the best place to address this problem would be in appropriate .c and .h header files such as those that have already been cited by Karl Williamson in this ticket.

For many uses, however, we can get by with changes to the hints/netbsd.sh file included in the Perl 5 core distribution.  If you are not already familiar with that file, which is run as part of the configuration process, please take a look at it.

Thank you very much.
-- 
James E Keenan (jkeenan@cpan.org)

---
via perlbug:  queue: perl5 status: open
https://rt.perl.org/Ticket/Display.html?id=134023



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About