develooper Front page | perl.perl5.porters | Postings from May 2019

[perl #128109] Issues with (?0) being wrong in 5.24 (rc?)

Thread Next
From:
Hugo van der Sanden via RT
Date:
May 10, 2019 19:59
Subject:
[perl #128109] Issues with (?0) being wrong in 5.24 (rc?)
Message ID:
rt-4.0.24-30830-1557518362-328.128109-15-0@perl.org
On Mon, 12 Mar 2018 13:05:30 -0700, khw wrote:
> On Thu, 05 Jan 2017 13:15:02 -0800, jkeenan wrote:
> > On Tue, 10 May 2016 07:53:23 GMT, demerphq wrote:
> > > Fixed in
> > >
> > > da7cf1cc7cedc01f35ceb6724e8260c3b0ee0d12 fix #128109 - do not move
> > > RExC_open_parens[0] in reginsert
> > >
> > > Yves
> > 
> > I am trying to determine whether this ticket is closable.
> > 
> > The commit above did not include any tests, and, since the original
> > description of the problem was very general, we don't have a good way
> > of determining whether the problem was solved.
> > 
> > Thank you very much.
> 
> Yves, what should we do about this?

(I'm not Yves but) I think we should close it. There's no particular useful content here beyond what was fixed by the associated patch. If there are remaining problems it seems most likely to me they'll be found by fuzzing, and this ticket is unlikely to be a useful reference in the event anything is found.

Doing that now, feel free to reopen if you disagree.

Hugo

---
via perlbug:  queue: perl5 status: open
https://rt.perl.org/Ticket/Display.html?id=128109

Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About