develooper Front page | perl.perl5.porters | Postings from March 2019

[perl #132577] BBC Module::Install broken by0301e899536a22752f40481d8a1d141b7a7dda82

Thread Previous
From:
Karl Williamson via RT
Date:
March 29, 2019 02:33
Subject:
[perl #132577] BBC Module::Install broken by0301e899536a22752f40481d8a1d141b7a7dda82
Message ID:
rt-4.0.24-10621-1553826784-880.132577-15-0@perl.org
On Fri, 20 Apr 2018 03:54:26 -0700, xsawyerx@gmail.com wrote:
> 
> 
> On 04/20/2018 12:36 AM, Dave Mitchell wrote:
> > On Wed, Dec 27, 2017 at 09:23:52PM +0000, Zefram wrote:
> >> Following discussion with Sawyer, where he determined that
> >> there is a need for more time to fix Module::Install distros,
> >> I have reintroduced the perl_parse() exit(0) bug in commit
> >> 857320cbf85e762add18885ae8a197b5e0c21b69.
> >>
> >> I tried adding a deprecation warning, but this turned out to cause noise.
> >> There's an INIT block buried deep inside Test::More, so the warning
> >> would fire for any test script that loaded Test::More and then did a
> >> skip_all in a BEGIN block, which is quite a common pattern.  The logic
> >> around this INIT block doesn't really care whether it runs in this case,
> >> so there's nothing to fix.  Rather than get these false warnings, Sawyer
> >> decided it was better to have no deprecation warning.
> >>
> >> We expect to fix the bug again during the 5.29 cycle.  This would consist
> >> of reverting most of commit 857320cbf85e762add18885ae8a197b5e0c21b69:
> >> the documentation and code changes in perl.c, and the test changes in
> >> t/op/blocks.t.  This issue should block 5.30.0.
> > Since this change has been reverted for 5.28, I presume I can remove this
> > ticket from the 5.28 blockers list.
> 
> Yup.

Pinging this ticket

-- 
Karl Williamson


---
via perlbug:  queue: perl5 status: open
https://rt.perl.org/Ticket/Display.html?id=132577

Thread Previous


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About