develooper Front page | perl.perl5.porters | Postings from March 2019

Re: [perl #133951] 5.28+ fails to build: miniperl can't locatestrict

Thread Previous | Thread Next
From:
Eric Brine
Date:
March 24, 2019 20:57
Subject:
Re: [perl #133951] 5.28+ fails to build: miniperl can't locatestrict
Message ID:
CALJW-qGXspkMx1D2-m2xbOcP5e-FefiwKQrOvVShapUgMKzi+Q@mail.gmail.com
On Sun, Mar 24, 2019 at 8:37 AM James E Keenan via RT <
perlbug-followup@perl.org> wrote:

> Also, do you have recommendations for patches?
>

No. _perl_getcwd is fundamentally flawed (and so is _perl_abs_path). It's
not possible to reliably obtain the cwd in Pure Perl without executing an
external program. Cwd::getcwd should be builtin.

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About