develooper Front page | perl.perl5.porters | Postings from February 2019

[perl #133803] ExtUtils-MakeMaker in perl 5.28 armv5te fails

From:
Tony Cook via RT
Date:
February 6, 2019 04:18
Subject:
[perl #133803] ExtUtils-MakeMaker in perl 5.28 armv5te fails
Message ID:
rt-4.0.24-30506-1549426723-1873.133803-15-0@perl.org
On Mon, 28 Jan 2019 04:52:14 -0800, rob@allenonline.me.uk wrote:
> 


> Maintainer of ExtUtils::MakeMaker suggested this test 'perl -Mversion -e1'
> which gives:

> "Can't use string ("version::regex::LAX_DOTTED_DECIM"...) as a SCALAR ref while "strict refs" in 
> use at /usr/share/perl5/core_perl/version.pm line 21.
> Compilation failed in require.
> BEGIN failed--compilation aborted."

That checks your system perl, but for a perl build you need to check the bundled modules with the perl you're building.

Inside the perl build directory please run:

  ./miniperl -Mversion -e0

Please include everything that outputs if it fails.

This uses miniperl, since that's what make_ext.pl will be using.  It skips adding -Ilib since lib/buildcustomize.pl should have been built at this point and miniperl will load that.

Tony

---
via perlbug:  queue: perl5 status: open
https://rt.perl.org/Ticket/Display.html?id=133803



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About