develooper Front page | perl.perl5.porters | Postings from January 2019

[perl #133803] ExtUtils-MakeMaker in perl 5.28 armv5te fails

Thread Previous | Thread Next
From:
James E Keenan via RT
Date:
January 28, 2019 17:06
Subject:
[perl #133803] ExtUtils-MakeMaker in perl 5.28 armv5te fails
Message ID:
rt-4.0.24-1085-1548695193-1884.133803-15-0@perl.org
On Mon, 28 Jan 2019 12:52:14 GMT, rob@allenonline.me.uk wrote:
> 

[Reformatting so that content displays better in RT -- jkeenan]

Any attempt to access CPAN on ArchlinuxArm on armv5te processors results in:

"Can't locate ExtUtils/MakeMaker/version/vpp.pm in @INC (you may need to install the 
ExtUtils::MakeMaker::version::vpp module) (@INC contains: /usr/lib/perl5/5.28/site_perl 
/usr/share/perl5/site_perl /usr/lib/perl5/5.28/vendor_perl /usr/share/perl5/vendor_perl 
/usr/lib/perl5/5.28/core_perl /usr/share/perl5/core_perl) at (eval 14) line 1."

Maintainer of ExtUtils::MakeMaker suggested this test 'perl -Mversion -e1' which gives:

"Can't use string ("version::regex::LAX_DOTTED_DECIM"...) as a SCALAR ref while "strict refs" in use at /usr/share/perl5/core_perl/version.pm line 21.
Compilation failed in require.
BEGIN failed--compilation aborted."

A number of us have hit this problem:

https://archlinuxarm.org/forum/viewtopic.php?f=57&t=13134



---
via perlbug:  queue: perl5 status: new
https://rt.perl.org/Ticket/Display.html?id=133803

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About