develooper Front page | perl.perl5.porters | Postings from November 2018

Re: [perl #133624] Data::Dumper 2.172 failure on Perl 5.8.8 andolder

Thread Previous | Thread Next
From:
Sawyer X
Date:
November 10, 2018 09:33
Subject:
Re: [perl #133624] Data::Dumper 2.172 failure on Perl 5.8.8 andolder
Message ID:
df10570f-5b96-e353-b4d3-cfd89c00a581@gmail.com

On 10/28/18 3:52 PM, James E Keenan via RT wrote:
> On Sun, 28 Oct 2018 12:38:07 GMT, skaji@cpan.org wrote:
>> While Data-Dumper-2.161 has DEFINE => '-DUSE_PPPORT_H' in Makefile.PL,
>> Data-Dumper-2.172 does not.
>> https://metacpan.org/source/SMUELLER/Data-Dumper-2.161/Makefile.PL#L17
>> https://metacpan.org/source/XSAWYERX/Data-Dumper-2.172/Makefile.PL
>>
>> If I added DEFINE => '-DUSE_PPPORT_H' to Data-Dumper-2.172's
>> Makefile.PL manually,
>> I was able to build Data-Dumper-2.172 on perl-5.8.8.
>>
> An excellent insight!  I can confirm that modifying the Makefile.PL in Data-Dumper-2.172's Makefile.PL enabled me to run 'make' and 'make test' and get a PASS.
>
> I then built and force-installed a perl-5.8.4 via perlbrew, installed the latest Test::More against that perl, then attempted to install Data-Dumper-2.172.  As grinnz originally reported, 'make' failed.  However, when I edited the Makefile.PL in the manner suggested, 'make' completed and 'make test' was graded PASS.
>
> So it appears we need a new CPAN release of Data::Dumper with a corrected Makefile.PL.
>
> Sawyer, can you handle that?


I'm not sure why the diff is there.


I'll rebuild and release today.

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About