develooper Front page | perl.perl5.porters | Postings from October 2018

[perl #133587] toolchain possibilities for avoiding "binariesmismatched" error

Thread Previous | Thread Next
From:
Dan Book via RT
Date:
October 18, 2018 20:21
Subject:
[perl #133587] toolchain possibilities for avoiding "binariesmismatched" error
Message ID:
rt-4.0.24-6377-1539894061-1489.133587-15-0@perl.org
On Thu, 18 Oct 2018 13:18:40 -0700, grinnz@gmail.com wrote:
> On Thu, 18 Oct 2018 13:00:06 -0700, frederik@ofb.net wrote:
> > Also I'm confused by the syntax, I would have thought the second
> > command should also report the module being up to date:
> >
> > $ cpanm Compress::Raw::Zlib@2.076
> > Compress::Raw::Zlib is up to date. (2.076)
> > $ cpanm 'Compress::Raw::Zlib~>=2.076'
> > --> Working on Compress::Raw::Zlib
> > Fetching http://www.cpan.org/authors/id/P/PM/PMQS/Compress-Raw-Zlib-
> > 2.081.tar.g
> 
> 2.076 is not the latest version. @2.076 arranges to have exactly that
> version installed, whereas ~2.076 arranges for that version or higher,
> equivalent to ~'>= 2.076', and it seems cpanm will take this to mean
> that it should upgrade the module.

You can pass --skip-satisfied to cause it to skip installing the module when it's not at the latest version, but satisfies the specified version range.

-Dan

---
via perlbug:  queue: perl5 status: open
https://rt.perl.org/Ticket/Display.html?id=133587

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About