develooper Front page | perl.perl5.porters | Postings from October 2018

Re: [perl #133587] toolchain possibilities for avoiding "binariesmismatched" error

Thread Previous | Thread Next
From:
frederik
Date:
October 18, 2018 19:59
Subject:
Re: [perl #133587] toolchain possibilities for avoiding "binariesmismatched" error
Message ID:
20181018195939.55l75v34mlo2vwjq@ofb.net
On Thu, Oct 18, 2018 at 12:24:18PM -0700, Dan Book via RT wrote:
> On Thu, 18 Oct 2018 11:59:00 -0700, frederik@ofb.net wrote:
> > I guess a summary of this thread is that most Perl developers either
> > (1) don't use Perl on systems where they don't have root access, or
> > (2) compile their own Perl and install it somewhere in ~/ in such
> > cases.
> 
> I don't think it's useful to try to categorize what "most" Perl developers do based on a few people's limited perception of the userbase.

Oh sorry I meant ... "developers *of* Perl" not "developers *with*
Perl". One of the questions I have been trying to answer is why other
contributors to this thread don't run into the same problems that I'm
running into, why Dave considers a situation which I had thought would
be a default one, to be "relatively rare", why Andy was surprised that
I have Compress::Raw::Zlib installed locally, etc.

> 'cpan' and 'cpanm' already skip installing modules which already exist in PERL5LIB, unless the existing version does not satisfy the requirement. CPAN module dependencies often include a version requirement, and the 'cpanm' client can take a version requirement directly: Some::Module@1.23

Thank you, that's helpful to know. In my email of "Tue, 21 Aug 2018
16:43:58 -0700" I mentioned having noticed Compress::Raw::Zlib
reappear in ~/.local after uninstalling it. Presumably I ran 'cpan -r'
and something depended on the latest version?
/usr/lib/perl5/5.28/core_perl/Compress/Raw/Zlib.pm has 2.076, vs 2.081
for the latest version?

Also I'm confused by the syntax, I would have thought the second
command should also report the module being up to date:

$ cpanm Compress::Raw::Zlib@2.076   
Compress::Raw::Zlib is up to date. (2.076)
$ cpanm 'Compress::Raw::Zlib~>=2.076'
--> Working on Compress::Raw::Zlib
Fetching http://www.cpan.org/authors/id/P/PM/PMQS/Compress-Raw-Zlib-2.081.tar.g

Thanks,

Frederick

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About