develooper Front page | perl.perl5.porters | Postings from October 2018

Re: [perl #133558] perl 5.26: use lib pragma issue in IBM AIX

Thread Previous | Thread Next
From:
H.Merijn Brand
Date:
October 17, 2018 07:32
Subject:
Re: [perl #133558] perl 5.26: use lib pragma issue in IBM AIX
Message ID:
20181017092944.583b6d58@pc09.procura.nl
On Wed, 17 Oct 2018 09:13:19 +0200, "H.Merijn Brand"
<h.m.brand@xs4all.nl> wrote:

> >     ccversion=''
> >     gccversion=''  
> 
> I find it weird that it did not detect your ccversion

These methods are currently used:

$ lslpp -ql -Ou vac.C | grep -v '^Path' | head -1
  vac.C                    12.1.0.12  COMMITTED  IBM XL C Compiler

$ lslpp -L | grep 'C for AIX Compiler$'
  vac.msg.en_US.C          12.1.0.12    C     F    XL C for AIX Compiler

$ lslpp -L | grep 'IBM C and C++ Compilers LUM$'

These might need to be added:

$ what `which xlc_r` | grep -i version: | sort -u
         Version: 12.01.0000.0012

$ strings `which xlc_r` | grep -i version: | sort -u
@(#) Version: 12.01.0000.0012
Version: 12.01.0000.0012

$ gxlc --version
IBM XL C/C++ for AIX, V12.1 (5765-J02, 5725-C72)
Version: 12.01.0000.0012

(note that my vac/gxlc does not know about -dumpversion)

-- 
H.Merijn Brand  http://tux.nl   Perl Monger  http://amsterdam.pm.org/
using perl5.00307 .. 5.29   porting perl5 on HP-UX, AIX, and openSUSE
http://mirrors.develooper.com/hpux/        http://www.test-smoke.org/
http://qa.perl.org   http://www.goldmark.org/jeff/stupid-disclaimers/

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About