develooper Front page | perl.perl5.porters | Postings from October 2018

Re: [perl #133587] toolchain possibilities for avoiding "binariesmismatched" error

Thread Previous
From:
frederik
Date:
October 16, 2018 12:06
Subject:
Re: [perl #133587] toolchain possibilities for avoiding "binariesmismatched" error
Message ID:
20181016120603.no4edcyd4hrdkzpp@ofb.net
Yesterday I wrote "I will do some investigation and try to figure out
what is giving us different results before I reply to the rest of your
message." It looks like Graham Knop saved me the trouble - thank you!

> Date: Tue, 16 Oct 2018 04:15:50 -0700
> From: Graham Knop via RT <perlbug-followup@perl.org>
>
> This is true if you have permissions to install in site_perl.  But if
> you try to install modules using system perl without running as root,
> you probably won't have access to do that.
>
> In that case, both CPAN.pm and cpanm will default to using local::lib
> and installing into ~/perl5, using ExtUtils::MakeMaker's INSTALL_BASE
> option and Module::Build's --install_base option.  Those options don't
> use versioned paths.

Thread Previous


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About