develooper Front page | perl.perl5.porters | Postings from October 2018

Re: [perl #133587] toolchain possibilities for avoiding "binariesmismatched" error

Thread Previous | Thread Next
From:
Slaven Rezic
Date:
October 15, 2018 21:10
Subject:
Re: [perl #133587] toolchain possibilities for avoiding "binariesmismatched" error
Message ID:
87bm7uor0t.fsf@cvrsnica.herceg.de
"Dan Book via RT" <perlbug-followup@perl.org> writes:

> On Mon, 15 Oct 2018 13:23:29 -0700, slaven@rezic.de wrote:
>> Leon Timmermans <fawaka@gmail.com> writes:
>> 
>> > On Mon, Oct 15, 2018 at 1:39 PM Dave Mitchell <davem@iabyn.com>
>> > wrote:
>> >> No, what you really want to do is, if installing under your home
>> >> directory, install version-sensitive files under version-specific
>> >> paths.
>> >> This appears to be a infelicity in the current local::lib tool. I
>> >> don't
>> >> know a lot about local::lib, and I'm not a "toolchain guy", so I
>> >> don't
>> >> know whether there's a good reason why local::lib does things the
>> >> way it
>> >> does or whether it can be altered / extended to include versions in
>> >> paths.
>> >
>> > local::lib doesn't support version/configuration specific paths
>> > because PERL5LIB doesn't support such a thing.
>> 
>> Hmmm. "perldoc perlrun" says:
>> 
>> PERL5LIB        [...] Any architecture-specific and version-specific
>>                 directories, such as version/archname/, version/, or
>>                 archname/ under the specified locations are
>> automatically
>>                 included if they exist
>> 
>> So PERL5LIB does the right thing. Unfortunately EUMM's INSTALL_BASE
>> does
>> not support this.
>> 
>
> This documentation only mentions 'version-specific' since Perl 5.18.0.
> The documentation for https://perldoc.pl/lib mentions it since Perl
> 5.8.9. I'm not sure if this reflects when the feature was actually
> present, but local::lib does need to support older Perls.

I still assert that it's not local::lib which is doing things wrong, but
EUMM (and probably MB), because by using INSTALL_BASE things don't end
up in version-specific directories if it is needed. Maybe this could be
fixed. If this could be fixed, then local::lib could simply raise the
EUMM (and maybe MB) prereq versions (as it already does nowadays).

BTW, even perl 5.8.1 supports version-specific directories. I don't have
older perls for experimenting.

Regards,
    Slaven

-- 
Slaven Rezic - slaven <at> rezic <dot> de
  BBBike - route planner for cyclists in Berlin
  WWW version:                           http://www.bbbike.de
  Perl/Tk version for Unix and Windows:  http://bbbike.sourceforge.net

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About