develooper Front page | perl.perl5.porters | Postings from July 2018

[perl #133024] [PATCH] remove distros from needing ppport.h in core

From:
bulk88 via RT
Date:
July 20, 2018 20:05
Subject:
[perl #133024] [PATCH] remove distros from needing ppport.h in core
Message ID:
rt-4.0.24-29584-1532117145-708.133024-15-0@perl.org
On Sat, 24 Mar 2018 16:51:22 -0700, bulk88 wrote:
> This is a bug report for perl from bulk88@hotmail.com,
> generated with the help of perlbug 1.41 running under perl 5.27.9.
> 
> 
> -----------------------------------------------------------------
> [Please describe your issue here]
> 
> See attached patch. This could be for 5.28, but doesn't have to be, 
> unless a new build process flow without mkppport as a dep on Win32 is 
> put in, but after this patch Win32API::File is the only XS module left 
> on Win32 perl that needs ppport.h since SysV and DBFile dont build on 
> Win32. Tackling the last 3 ppport needing modules requires CPAN author 
> participation.

Bump.

---
via perlbug:  queue: perl5 status: new
https://rt.perl.org/Ticket/Display.html?id=133024



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About