develooper Front page | perl.perl5.porters | Postings from February 2018

[perl #131046] [PATCH] Carp: Do not crash when reading @DB::args

Thread Previous | Thread Next
Father Chrysostomos via RT
February 25, 2018 18:45
[perl #131046] [PATCH] Carp: Do not crash when reading @DB::args
Message ID:
On Sun, 25 Feb 2018 02:19:50 -0800, demerphq wrote:
> On 24 February 2018 at 16:39, Father Chrysostomos via RT
> <> wrote:
> > That puts a burden on perl maintainers to remember which version
> > scheme to use in each case.  I seem to remember it was Ricardo Signes
> > that ruled that upstream-blead modules should not have underscores in
> > their versions.  That makes things much simpler for me, at least.
> This just came up in another context for me. Doesnt this policy just
> move the burden around? Who is responsible for bumping the version
> then? The first person to change the file in a given release?

Yes, and we have a porting test that politely reminds the first person who changes each module.

> The RM?
> It still seems to me that a version bump every patch is the sanest way
> to deal with this stuff while at the same time not externalizing the
> costs of the version updates onto someone else...


Father Chrysostomos

via perlbug:  queue: perl5 status: open

Thread Previous | Thread Next Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at | Group listing | About