develooper Front page | perl.perl5.porters | Postings from February 2018

Re: [perl #132901] setlocale's return value is broken

Thread Previous | Thread Next
From:
Karl Williamson
Date:
February 25, 2018 16:13
Subject:
Re: [perl #132901] setlocale's return value is broken
Message ID:
f294428e-a75a-8a76-a584-9e797e0da9a2@khwilliamson.com
On 02/25/2018 03:03 AM, Slaven Rezic wrote:
> "karl williamson via RT" <perlbug-followup@perl.org> writes:
> 
>> On 02/24/2018 01:14 PM, Karl Williamson wrote:
>>> On 02/24/2018 02:00 AM, Slaven Rezic wrote:
>>>> Karl Williamson <public@khwilliamson.com> writes:
>>>>
>>>>> On 02/23/2018 02:41 PM, Slaven Rezic wrote:
>>>>>> Karl Williamson <public@khwilliamson.com> writes:
>>>>>>
>>>>>>> On 02/23/2018 12:33 AM, slaven@rezic.de wrote:
>>>>>>>> # New Ticket Created by  slaven@rezic.de
>>>>>>>> # Please include the string:  [perl #132901]
>>>>>>>> # in the subject line of all future correspondence about this issue.
>>>>>>>> # <URL: https://rt.perl.org/Ticket/Display.html?id=132901 >
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> This is a bug report for perl from slaven@rezic.de,
>>>>>>>> generated with the help of perlbug 1.41 running under perl 5.27.9.
>>>>>>>>
>>
>> I believe this is fixed in blead; please verify.
>>
> 
> No, it's still not fixed:
> 
> $ env LC_ALL=de_DE.UTF-8 ./perl -Ilib -MTest::More=no_plan -MPOSIX=setlocale,LC_ALL -e 'is setlocale(LC_ALL), "de_DE.UTF-8"'
> not ok 1
> #   Failed test at -e line 1.
> #          got: '�^'
> #     expected: 'de_DE.UTF-8'
> 1..1
> # Looks like you failed 1 test of 1.
> 
> $ env LC_ALL=de_DE.UTF-8 ./perl -Ilib -V|grep Commit.id
>    Commit id: c1cc29fd0c75ba66cac01113aa5a22009dcea306
> 

Sorry, somehow not all the commits I intended to push actually got 
pushed.  The commit I believe will fix the problem is
7a60910d1bd9081951d3509805c035b0c4bcbe79

And, yes, I will add a test

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About