develooper Front page | perl.perl5.porters | Postings from February 2018

Re: [perl #128627] Quadmath builds fail on Cygwin in ext/POSIX

Thread Previous
From:
Leon Timmermans
Date:
February 1, 2018 13:24
Subject:
Re: [perl #128627] Quadmath builds fail on Cygwin in ext/POSIX
Message ID:
CAHhgV8gj81NKfW1QgjwMmknhQe6rK4d7k1tXzWuH5mcgZov2wA@mail.gmail.com
On Mon, Jan 8, 2018 at 3:49 PM, (Peter J. Acklam) via RT
<perlbug-followup@perl.org> wrote:
> As for the the paths in libpth. For perl that is installed with Cygwin,
> I get
>
>     $ perl -V:libpth
>     libpth='/usr/lib';

That's clearly not going to work

> for the perl I compiled myself (with quadmath support), I get
>
>     $ /usr/site/perl-5.27.7/bin/perl -V:libpth
>     libpth='/usr/site/gcc-7.2.0/lib /usr/site/gcc-7.2.0/lib/gcc/x86_64-unknown-cygwin/7.2.0/include-fixed /usr/lib /usr/lib/../lib/../include/w32api /usr/local/lib /lib';

That should work iff you use exactly the same compiler, the one you
listed above doesn't match.

Leon

Thread Previous


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About