develooper Front page | perl.perl5.porters | Postings from January 2018

Re: [perl #132766] Recent changes to inline.h have broken VC6 buildon Windows

Thread Previous | Thread Next
From:
Steve Hay via perl5-porters
Date:
January 29, 2018 14:01
Subject:
Re: [perl #132766] Recent changes to inline.h have broken VC6 buildon Windows
Message ID:
CADED=K5BpiOimV6iS7cmYywv7xBk1QasAwbTe90cgw1_tVsVvg@mail.gmail.com
On 29 January 2018 at 09:17, Steve Hay <steve.m.hay@googlemail.com> wrote:
> On 29 January 2018 at 08:29, Steve Hay <steve.m.hay@googlemail.com> wrote:
>> On 28 January 2018 at 17:41, Karl Williamson <public@khwilliamson.com> wrote:
>>> On 01/25/2018 09:04 PM, Karl Williamson wrote:
>>>>
>>>> Nonetheless, until the project decides it won't support C89 anymore, we
>>>> have to fix bugs like this.
>>>
>>>
>>> And similarly for MSVC6.
>>>
>>> With that in mind, please test the latest smoke-me/khw-variant, as I have
>>> special cased MSVC6, so that it hopefully works.
>>
>> Yes, that fixes the VC6 build. Thanks.
>
> I get a test failure after building it, though :-/
>
> C:\Dev\Git\perl\t>.\perl harness ../ext/XS-APItest/t/utf8.t
> ../ext/XS-APItest/t/utf8.t .. 1/? Use of code point 0xFFFFFFFF is not
> allowed; the permissible max is 0x7FFFFFFF at t/utf8.t line 149.
> # Tests were run but no plan was declared and done_testing() was not seen.
> # Looks like your test exited with 255 just after 324.
> ../ext/XS-APItest/t/utf8.t .. Dubious, test returned 255 (wstat 65280, 0xff00)
> All 324 subtests passed
>
> Test Summary Report
> -------------------
> ../ext/XS-APItest/t/utf8.t (Wstat: 65280 Tests: 324 Failed: 0)
>   Non-zero exit status: 255
>   Parse errors: No plan found in TAP output
> Files=1, Tests=324,  0 wallclock secs ( 0.02 usr +  0.03 sys =  0.05 CPU)
> Result: FAIL

(I get the same with VC14 too, so this isn't VC6-specific.)

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About