develooper Front page | perl.perl5.porters | Postings from January 2018

Re: [perl #132761] [PATCH] Devel::PPPort for older Perl versions

Thread Previous | Thread Next
From:
pali
Date:
January 26, 2018 19:11
Subject:
Re: [perl #132761] [PATCH] Devel::PPPort for older Perl versions
Message ID:
20180126191119.GA8236@pali
On Thursday 25 January 2018 09:30:13 pali@cpan.org wrote:
> On Wednesday 24 January 2018 19:41:02 Tony Cook via RT wrote:
> > -croak_xs_usage(pTHX_ const CV *const cv, const char *const params)
> > +croak_xs_usage(const CV *const cv, const char *const params)
> >  {
> >      const GV *const gv = CvGV(cv);
> 
> Does not CvGV need to declare dTHX; when pTHX_ is not supplied as
> argument?

Also croak() needs it. In attachment are another two patches which
should fix these problems.

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About