develooper Front page | perl.perl5.porters | Postings from January 2018

[perl #132760] Blead Breaks CPAN: YANICK/List-Lazy-0.3.0.tar.gz

Thread Previous | Thread Next
From:
James E Keenan via RT
Date:
January 24, 2018 20:18
Subject:
[perl #132760] Blead Breaks CPAN: YANICK/List-Lazy-0.3.0.tar.gz
Message ID:
rt-4.0.24-22666-1516825106-1726.132760-15-0@perl.org
On Wed, 24 Jan 2018 20:04:24 GMT, slaven@rezic.de wrote:
> 
> This is a bug report for perl from slaven@rezic.de,
> generated with the help of perlbug 1.41 running under perl 5.27.8.
> 
> 
> -----------------------------------------------------------------
> List-Lazy-0.3.0 does not work anymore since v5.27.7-212-g894f226e51.
> This is the change which swapped signatures and attributes.
> This change is already documented in perldelta, but I have just
> two notes:
> 
> - The error output does not look nice. In this case it begins with
> 
> Array found where operator expected at
> /home/eserte/.cpan/build/2018012418/List-Lazy-0.3.0-
> 2/blib/lib/List/Lazy.pm line 43, near "$$@)"
>         (Missing operator before @)?)
> "my" variable $step masks earlier declaration in same statement at
> /home/eserte/.cpan/build/2018012418/List-Lazy-0.3.0-
> 2/blib/lib/List/Lazy.pm line 44.
> syntax error at /home/eserte/.cpan/build/2018012418/List-Lazy-0.3.0-
> 2/blib/lib/List/Lazy.pm line 36, near ") :"
> Global symbol "$generator" requires explicit package name (did you
> forget to declare "my $generator"?) at
> /home/eserte/.cpan/build/2018012418/List-Lazy-0.3.0-
> 2/blib/lib/List/Lazy.pm line 38.
> Global symbol "$state" requires explicit package name (did you forget
> to declare "my $state"?) at /home/eserte/.cpan/build/2018012418/List-
> Lazy-0.3.0-2/blib/lib/List/Lazy.pm line 39.
> Global symbol "$min" requires explicit package name (did you forget to
> declare "my $min"?) at /home/eserte/.cpan/build/2018012418/List-Lazy-
> 0.3.0-2/blib/lib/List/Lazy.pm line 43.
> Global symbol "$max" requires explicit package name (did you forget to
> declare "my $max"?) at /home/eserte/.cpan/build/2018012418/List-Lazy-
> 0.3.0-2/blib/lib/List/Lazy.pm line 43.
> Global symbol "$step" requires explicit package name (did you forget
> to declare "my $step"?) at /home/eserte/.cpan/build/2018012418/List-
> Lazy-0.3.0-2/blib/lib/List/Lazy.pm line 43.
> Invalid separator character '{' in attribute list at
> /home/eserte/.cpan/build/2018012418/List-Lazy-0.3.0-
> 2/blib/lib/List/Lazy.pm line 44, near "$step : sub "
> Global symbol "$step" requires explicit package name (did you forget
> to declare "my $step"?) at /home/eserte/.cpan/build/2018012418/List-
> Lazy-0.3.0-2/blib/lib/List/Lazy.pm line 44.
> ...
> 
> which does not really say anything about the problem. Is it possible
> to detect this situation and improve diagnostics?
> 
> - What does this change means in terms of usability of signatures?
> Users
>   mixing signatures and prototypes must increase their perl
> prerequisite
>   from 5.22 to 5.28, which may mean it could be less likely that
>   signatures are used in the next time. Is this worth for this change?
> 
> BTW, the issue for the CPAN module is
> https://github.com/yanick/List-Lazy/issues/3
> 
> -- Slaven
> 

Test failures confirmed.

-- 
James E Keenan (jkeenan@cpan.org)

---
via perlbug:  queue: perl5 status: new
https://rt.perl.org/Ticket/Display.html?id=132760

Thread Previous | Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About