develooper Front page | perl.perl5.porters | Postings from December 2017

Blead no longer compiles with these options:

From:
Karl Williamson
Date:
December 11, 2017 17:16
Subject:
Blead no longer compiles with these options:
Message ID:
1e21db42-6d37-9814-9663-d987c914eb84@khwilliamson.com
  config_args='-des -Uversiononly -Dprefix=/home/khw/blead -Dusedevel 
-A'optimize =-ggdb3' -A'optimize=-O0' -Accflags='-DPERL_BOOL_AS_CHAR' 
-Accflags='-Wno-deprecated' -Accflags='-DPERL_EXTERNAL_GLOB' 
-Dman1dir=none -Dman3dir=none -Dcc=g++  -DDEBUGGING -Dusemorebits 
-Dusecbacktrace -Dusethreads'


I suspect it is because of the g++

The failure is

APItest.c:7295:36: error: cannot convert ‘FILE* {aka _IO_FILE*}’ to 
‘PerlIOl** {aka _PerlIO**}’ in assignment

and the same at line 7301



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About