develooper Front page | perl.perl5.porters | Postings from November 2017

Deadline for the $[ deprecation: 5.30?

Thread Next
From:
ilmari
Date:
November 23, 2017 10:43
Subject:
Deadline for the $[ deprecation: 5.30?
Message ID:
d8j60a12s3d.fsf@dalvik.ping.uio.no
Hi Porters,

At last year's Perl5 Core Hackathon in Amsterdam, we went through all
the deprecation warnings and added deadlines for their removal, but we
missed $[.  At this year's hackathon this was brought up, and I seem to
recall we decided to set a deadline of 5.30, but I'm not 100% certain,
and can't find any mention of it in the hackathon wiki
(https://github.com/p5h/2017/wiki) or my IRC logs.

Does anyone object to 5.30 as the deadline?  It's been emitting a
deprecation warning since 5.12.

At the hackathon I volunteered to submit patches to all the CPAN modules
that would break (and still otherwise work on recent perls). I stand by
this offer.

- ilmari
-- 
"The surreality of the universe tends towards a maximum" -- Skud's Law
"Never formulate a law or axiom that you're not prepared to live with
 the consequences of."                              -- Skud's Meta-Law

Thread Next


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About