develooper Front page | perl.perl5.porters | Postings from October 2017

[perl #132255] 5.26.1 Perl_fp_class_denorm still incompatible withCentOS 5

Thread Previous
From:
belg4mit @ pthbb . org
Date:
October 11, 2017 04:53
Subject:
[perl #132255] 5.26.1 Perl_fp_class_denorm still incompatible withCentOS 5
Message ID:
rt-4.0.24-7908-1507594847-702.132255-75-0@perl.org
# New Ticket Created by  belg4mit@pthbb.org 
# Please include the string:  [perl #132255]
# in the subject line of all future correspondence about this issue. 
# <URL: https://rt.perl.org/Ticket/Display.html?id=132255 >



This is a bug report for perl from belg4mit@pthbb.org,
generated with the help of perlbug 1.39 running under perl 5.18.1.


-----------------------------------------------------------------
[Please describe your issue here]
When trying to build Perl 5.26.1 I still encounter this error:

	sv.o: In function `S_hextract':
	sv.c:(.text+0xd94): undefined reference to `Perl_fp_class_denorm'
	collect2: ld returned 1 exit status
	make: *** [lib/buildcustomize.pl] Error 1

as originally reported in May by Yuki Kimoto
http://blogs.perl.org/users/yuki_kimoto/2017/05/i-cant-install-perl-5260-rc1-in-centos-5.html

and purportedly rectified by 
https://perl5.git.perl.org/perl.git/commitdiff/2749d0395cc1e21d69af38cde41490699fc6e3ab


[Please do not change anything below this line]
-----------------------------------------------------------------
---
Flags:
    category=core
    severity=low
---
Site configuration information for perl 5.18.1:

Configured by belg4mit at Sun Dec 22 14:13:46 EDT 2013.

Summary of my perl5 (revision 5 version 18 subversion 1) configuration:
   
  Platform:
    osname=linux, osvers=2.6.32.16-linode28, archname=i686-linux
    uname='linux db.pthbb.org 2.6.32.16-linode28 #1 smp sun jul 25 21:32:42 utc 2010 i686 i686 i386 gnulinux '
    config_args='-de'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=undef, usemultiplicity=undef
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=undef, use64bitall=undef, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='cc', ccflags ='-fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2',
    cppflags='-fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include'
    ccversion='', gccversion='4.1.2 20080704 (Red Hat 4.1.2-54)', gccosandvers=''
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=12
    ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=4, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -fstack-protector -L/usr/local/lib'
    libpth=/usr/local/lib /lib /usr/lib
    libs=-lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lc
    perllibs=-lnsl -ldl -lm -lcrypt -lutil -lc
    libc=/lib/libc-2.5.so, so=so, useshrplib=false, libperl=libperl.a
    gnulibc_version='2.5'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -L/usr/local/lib -fstack-protector'

Locally applied patches:
    

---
@INC for perl 5.18.1:
    /usr/local/lib/perl5/site_perl/5.18.1/i686-linux
    /usr/local/lib/perl5/site_perl/5.18.1
    /usr/local/lib/perl5/5.18.1/i686-linux
    /usr/local/lib/perl5/5.18.1
    .

---
Environment for perl 5.18.1:
    HOME=/home/belg4mit
    LANG=en_US
    LANGUAGE (unset)
    LD_LIBRARY_PATH (unset)
    LOGDIR (unset)
    PATH=/home/belg4mit/bin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin
    PERL_BADLANG (unset)
    SHELL=/bin/tcsh


Thread Previous


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About