develooper Front page | perl.perl5.porters | Postings from October 2017

[perl #132247] XSLoader and DynaLoader documentation bugs

Thread Previous
From:
James E Keenan via RT
Date:
October 9, 2017 16:32
Subject:
[perl #132247] XSLoader and DynaLoader documentation bugs
Message ID:
rt-4.0.24-17516-1507566770-157.132247-15-0@perl.org
On Sun, 08 Oct 2017 15:46:21 GMT, ben-goldberg@hotmail.com wrote:
> This is a bug report for perl from ben-goldberg@hotmail.com,
> generated with the help of perlbug 1.40 running under perl 5.20.2.
> 
> 
> -----------------------------------------------------------------
> [Please describe your issue here]
> 
> The documentation of XSLoader and DynaLoader do not make use of
> __PACKAGE__, and use outdated indirect method call syntax.
> 
> For example, this line from the doc:
> 
> XSLoader::load('YourPackage', $VERSION);
> 
> Should read:
> 
> XSLoader::load(__PACKAGE__, $VERSION);
> 
> Or alternatively:
> 
> __PACKAGE__->XSLoader::load($VERSION);
> 
> And this line:
> 
> bootstrap YourPackage $VERSION;
> 
> 
> Should read:
> 
> __PACKAGE__->bootstrap($VERSION);
> 
> 

Would you be able to provide a patch drawn against Perl 5 blead?

Thank you very much.

-- 
James E Keenan (jkeenan@cpan.org)

---
via perlbug:  queue: perl5 status: new
https://rt.perl.org/Ticket/Display.html?id=132247

Thread Previous


nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About