develooper Front page | perl.perl5.porters | Postings from October 2017

[perl #132080] Switch some core modules to XSLoader

From:
Todd Rinaldo via RT
Date:
October 3, 2017 20:50
Subject:
[perl #132080] Switch some core modules to XSLoader
Message ID:
rt-4.0.24-9071-1507063815-496.132080-15-0@perl.org
On Sun, 24 Sep 2017 13:16:57 -0700, xsawyerx@gmail.com wrote:
> 
> It appears toolchain is putting a lot of effort in tracking the lowest
> viable version of Perl to support and I believe we should keep what
> toolchain in mind when consider the versions we are willing to work hard
> to support. If toolchain decides to bring the minimum version to 5.8, we
> should at the very least discuss core module support for 5.6, possibly
> dropping it. (This is not a commitment, of course.)
> 

Perhaps it was a mistake to bring up this policy with regards to these patches. The patches listed are 5.6 compatible which seems to be our minimum toolchain version support is. Is there another reason not to merge this then?

The value here is that as long as Perl ships with modules that suggest Dynaloader is still needed, it's hard to set a good example elsewhere on CPAN.

Todd



---
via perlbug:  queue: perl5 status: open
https://rt.perl.org/Ticket/Display.html?id=132080



nntp.perl.org: Perl Programming lists via nntp and http.
Comments to Ask Bjørn Hansen at ask@perl.org | Group listing | About